Node.js 8: NULL Pointer Dereference
CVE-2018-1000168 is fixed in 5 products on 2 platforms, first by libnghttp2-14 1.30.0-1ubuntu1, released April 12, 2018. 1 other affected product has no fix yet. It is not reported as exploited. Patch Radar priority: High.
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| libnghttp2-14 · Ubuntu 18.04.6 LTS (bionic) | 1.30.0-1ubuntu1 | libnghttp2-14 1.30.0-1ubuntu1 | Apr 12, 2018 |
| nghttp2 · Ubuntu 18.04.6 LTS (bionic) | 1.30.0-1ubuntu1 | nghttp2 1.30.0-1ubuntu1 | Apr 12, 2018 |
| nghttp2-client · Ubuntu 18.04.6 LTS (bionic) | 1.30.0-1ubuntu1 | nghttp2-client 1.30.0-1ubuntu1 | Apr 12, 2018 |
| nghttp2-proxy · Ubuntu 18.04.6 LTS (bionic) | 1.30.0-1ubuntu1 | nghttp2-proxy 1.30.0-1ubuntu1 | Apr 12, 2018 |
| nghttp2-server · Ubuntu 18.04.6 LTS (bionic) | 1.30.0-1ubuntu1 | nghttp2-server 1.30.0-1ubuntu1 | Apr 12, 2018 |
| No fix yet | |||
| Node.js 8 (Windows apps) | No fix yet | no-fix | n/a |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.