CVE-2018-1000140

librelp0: rsyslog librelp version 1.2.14 and earlier contains a Buffer Overflow vulnerability in the checking of x509 certifica...

CVE-2018-1000140 is fixed in librelp0 on 1 platform by librelp0 1.2.14-3ubuntu0.1~esm1 (version 1.2.14-3ubuntu0.1~esm1), released March 22, 2018. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
n/a
Medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0934
95th percentile

rsyslog librelp version 1.2.14 and earlier contains a Buffer Overflow vulnerability in the checking of x509 certificates from a peer that can result in Remote code execution. This attack appear to be exploitable a remote attacker that can connect to rsyslog and trigger a stack buffer overflow by sending a specially crafted x509 certificate.

Where it's fixed

ProductFixed inFixReleased
Linux
librelp0 · Ubuntu 18.04.6 LTS (bionic) 1.2.14-3ubuntu0.1~esm1 librelp0 1.2.14-3ubuntu0.1~esm1 Mar 22, 2018

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.