CVE-2017-20165
node-debug: A vulnerability classified as problematic has been found in debug-js debug up to 3.0.x
CVE-2017-20165 is fixed in node-debug on 1 platform, first by DEBIAN-CVE-2017-20165, released January 9, 2023. It is not reported as exploited. Patch Radar priority: High.
High
CVSS
7.5
high
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0211
81st percentile
A vulnerability classified as problematic has been found in debug-js debug up to 3.0.x. This affects the function useColors of the file src/node.js. The manipulation of the argument str leads to inefficient regular expression complexity. Upgrading to version 3.1.0 is able to address this issue. The identifier of the patch is c38a0166c266a679c8de012d4eaccec3f944e685. It is recommended to upgrade the affected component. The identifier VDB-217665 was assigned to this vulnerability.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| node-debug · Debian 12.15 (bookworm) | 3.1.0-1 | DEBIAN-CVE-2017-20165 | Jan 9, 2023 |
| node-debug · Debian 13.5 (trixie) | 3.1.0-1 | DEBIAN-CVE-2017-20165 | Jan 9, 2023 |
| node-debug · Debian 14 | 3.1.0-1 | DEBIAN-CVE-2017-20165 | Jan 9, 2023 |