smarty3: Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom re...
CVE-2017-1000480 is fixed in smarty3 on 1 platform by smarty3 3.1.31+20161214.1.c7d42e4+selfpack1-3 (version 3.1.31+20161214.1.c7d42e4+selfpack1-3), released January 3, 2018. It is not reported as exploited. Patch Radar priority: Routine.
Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| smarty3 · Ubuntu 18.04.6 LTS (bionic) | 3.1.31+20161214.1.c7d42e4+selfpack1-3 | smarty3 3.1.31+20161214.1.c7d42e4+selfpack1-3 | Jan 3, 2018 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.