{
  "fix": "Node.js 4 4.6.0",
  "url": "https://patchblox.com/security/fix/windows-app/openjs.nodejs.4-4.6.0",
  "summary": "Node.js 4 4.6.0, released September 27, 2016, fixes 8 CVEs in Node.js 4. None of them is reported as exploited. Patch Radar priority: Urgent. The latest Node.js 4 is 4.8.7, which also fixes every one of these CVEs.",
  "platform": "windows-app",
  "type": "app-version",
  "title": "Node.js 4 4.6.0",
  "released": "2016-09-27T00:00:00Z",
  "priority": "Urgent",
  "priorityTier": 2,
  "priorityReason": "Closes CVE-2016-6303, rated Critical",
  "supported": true,
  "cveCount": 8,
  "exploitedCveCount": 0,
  "kevCveCount": 0,
  "ransomwareCveCount": 0,
  "maxEpss": 0.94697,
  "maxCvss": 9.8,
  "appliesTo": [
    {
      "product": "Node.js 4",
      "productUrl": "https://patchblox.com/security/product/windows-app/node.js-4",
      "fixedVersion": "4.6.0",
      "latestVersion": "4.8.7",
      "supported": true
    }
  ],
  "supersededBy": {
    "product": "Node.js 4",
    "latestVersion": "4.8.7",
    "productUrl": "https://patchblox.com/security/product/windows-app/node.js-4"
  },
  "cves": [
    {
      "cveId": "CVE-2016-6303",
      "url": "https://patchblox.com/security/cve/CVE-2016-6303",
      "title": "Node.js 4: Integer overflow in the MDC2_Update function in crypto/mdc2/mdc2dgst.c in OpenSSL before 1.1.0 allows\u2026",
      "priority": "Urgent",
      "cvss": 9.8,
      "epss": 0.31985,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    },
    {
      "cveId": "CVE-2016-2183",
      "url": "https://patchblox.com/security/cve/CVE-2016-2183",
      "title": "Node.js 4 and 1 other: Exposure of Sensitive Information to an Unauthorized Actor",
      "priority": "High",
      "cvss": 7.5,
      "epss": 0.94697,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    },
    {
      "cveId": "CVE-2016-6304",
      "url": "https://patchblox.com/security/cve/CVE-2016-6304",
      "title": "Node.js 4: Multiple memory leaks in t1_lib.c in OpenSSL before 1.0.1u, 1.0.2 before 1.0.2i, and 1.1.0 before 1.1.0a\u2026",
      "priority": "High",
      "cvss": 7.5,
      "epss": 0.63029,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    },
    {
      "cveId": "CVE-2016-7052",
      "url": "https://patchblox.com/security/cve/CVE-2016-7052",
      "title": "Node.js 4: crypto/x509/x509_vfy.c in OpenSSL 1.0.2i allows remote attackers to cause a denial of service (NULL pointer\u2026",
      "priority": "High",
      "cvss": 7.5,
      "epss": 0.29462,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    },
    {
      "cveId": "CVE-2016-6306",
      "url": "https://patchblox.com/security/cve/CVE-2016-6306",
      "title": "Node.js 4: The certificate parser in OpenSSL before 1.0.1u and 1.0.2 before 1.0.2i might allow remote attackers\u2026",
      "priority": "Routine",
      "cvss": 5.9,
      "epss": 0.41683,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    },
    {
      "cveId": "CVE-2016-5325",
      "url": "https://patchblox.com/security/cve/CVE-2016-5325",
      "title": "Node.js 4: CRLF injection vulnerability in the ServerResponse#writeHead function in Node.js 0.10.x before 0.10.47,\u2026",
      "priority": "Routine",
      "cvss": 6.1,
      "epss": 0.04093,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    },
    {
      "cveId": "CVE-2016-7099",
      "url": "https://patchblox.com/security/cve/CVE-2016-7099",
      "title": "Node.js 4: The tls.checkServerIdentity function in Node.js 0.10.x before 0.10.47, 0.12.x before 0.12.16, 4.x before\u2026",
      "priority": "Routine",
      "cvss": 5.9,
      "epss": 0.02841,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    },
    {
      "cveId": "CVE-2016-2178",
      "url": "https://patchblox.com/security/cve/CVE-2016-2178",
      "title": "Node.js 4: The dsa_sign_setup function in crypto/dsa/dsa_ossl.c in OpenSSL through 1.0.2h does not properly ensure\u2026",
      "priority": "Routine",
      "cvss": 5.5,
      "epss": 0.01242,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    }
  ],
  "dataAsOf": "2026-11-08T19:12:23Z",
  "attribution": {
    "text": "Data: Patchblox Patch Radar",
    "url": "https://patchblox.com/security/patch-radar",
    "terms": "https://patchblox.com/security/patch-radar/use-the-data"
  }
}