{
  "fix": "Node.js 4 4.2.3",
  "url": "https://patchblox.com/security/fix/windows-app/openjs.nodejs.4-4.2.3",
  "summary": "Node.js 4 4.2.3, released December 3, 2015, fixes 4 CVEs in Node.js 4. None of them is reported as exploited. Patch Radar priority: Urgent. The latest Node.js 4 is 4.8.7, which also fixes every one of these CVEs.",
  "platform": "windows-app",
  "type": "app-version",
  "title": "Node.js 4 4.2.3",
  "released": "2015-12-03T00:00:00Z",
  "priority": "Urgent",
  "priorityTier": 2,
  "priorityReason": "Closes CVE-2015-6764, rated Critical",
  "supported": true,
  "cveCount": 4,
  "exploitedCveCount": 0,
  "kevCveCount": 0,
  "ransomwareCveCount": 0,
  "maxEpss": 0.44016,
  "maxCvss": 9.8,
  "appliesTo": [
    {
      "product": "Node.js 4",
      "productUrl": "https://patchblox.com/security/product/windows-app/node.js-4",
      "fixedVersion": "4.2.3",
      "latestVersion": "4.8.7",
      "supported": true
    }
  ],
  "supersededBy": {
    "product": "Node.js 4",
    "latestVersion": "4.8.7",
    "productUrl": "https://patchblox.com/security/product/windows-app/node.js-4"
  },
  "cves": [
    {
      "cveId": "CVE-2015-6764",
      "url": "https://patchblox.com/security/cve/CVE-2015-6764",
      "title": "Node.js 4: The BasicJsonStringifier::SerializeJSArray function in json-stringifier.h in the JSON stringifier in\u2026",
      "priority": "Urgent",
      "cvss": 9.8,
      "epss": 0.05726,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    },
    {
      "cveId": "CVE-2015-3194",
      "url": "https://patchblox.com/security/cve/CVE-2015-3194",
      "title": "Node.js 4: crypto/rsa/rsa_ameth.c in OpenSSL 1.0.1 before 1.0.1q and 1.0.2 before 1.0.2e allows remote attackers\u2026",
      "priority": "High",
      "cvss": 7.5,
      "epss": 0.44016,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    },
    {
      "cveId": "CVE-2015-3193",
      "url": "https://patchblox.com/security/cve/CVE-2015-3193",
      "title": "Node.js 4: The Montgomery squaring implementation in crypto/bn/asm/x86_64-mont5.pl in OpenSSL 1.0.2 before 1.0.2e\u2026",
      "priority": "High",
      "cvss": 7.5,
      "epss": 0.25137,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    },
    {
      "cveId": "CVE-2015-8027",
      "url": "https://patchblox.com/security/cve/CVE-2015-8027",
      "title": "Node.js 4: Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability\u2026",
      "priority": "High",
      "cvss": 7.5,
      "epss": 0.05356,
      "kev": false,
      "ransomware": false,
      "exploited": false,
      "disclosed": false
    }
  ],
  "dataAsOf": "2026-11-08T00:53:09Z",
  "attribution": {
    "text": "Data: Patchblox Patch Radar",
    "url": "https://patchblox.com/security/patch-radar",
    "terms": "https://patchblox.com/security/patch-radar/use-the-data"
  }
}