# CVE-2026-32935: php-seclib: phpseclib is a PHP secure communications library

CVE-2026-32935 is fixed in 4 products on 1 platform, first by php-seclib 1.0.9-1ubuntu0.1~esm2, released March 19, 2026. It is not reported as exploited. Patch Radar priority: Routine.

- Web page: https://patchblox.com/security/cve/CVE-2026-32935
- Priority: Routine
- CVSS: 5.9 (Medium)
- EPSS: 0.0040
- CISA KEV: not listed
- Exploited (vendor report): no
- Publicly disclosed: no
- Published: Mar 19, 2026

## Description

phpseclib is a PHP secure communications library. Projects using versions 0.1.1 through 1.0.26, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when using AES in CBC mode. This issue has been fixed in versions 1.0.27, 2.0.52 and 3.0.50.

## Where it's fixed

| Platform | Product | Fixed in | Fix | Released |
|---|---|---|---|---|
| Linux | php-phpseclib Debian 12.15 (bookworm) | 2.0.42-1+deb12u3 | [DSA-6186-1](https://patchblox.com/security/data/fix/linux/dsa-6186-1.md) | Mar 29, 2026 |
| Linux | php-phpseclib Debian 13.5 (trixie) | 2.0.48-3+deb13u1 | [DSA-6186-1](https://patchblox.com/security/data/fix/linux/dsa-6186-1.md) | Mar 29, 2026 |
| Linux | php-phpseclib Debian 14 | 2.0.52-1 | [DEBIAN-CVE-2026-32935](https://patchblox.com/security/data/fix/linux/debian-cve-2026-32935.md) | Mar 20, 2026 |
| Linux | php-phpseclib Ubuntu 18.04.6 LTS (bionic) | 2.0.9-1ubuntu0.1~esm3 | [php-phpseclib 2.0.9-1ubuntu0.1~esm3](https://patchblox.com/security/data/fix/linux/ubuntu-bionic-php-phpseclib-2.0.9-1ubuntu0.1-esm3.md) | May 12, 2026 |
| Linux | php-phpseclib Ubuntu 20.04 LTS (focal) | 2.0.23-2ubuntu0.1~esm3 | [php-phpseclib 2.0.23-2ubuntu0.1~esm3](https://patchblox.com/security/data/fix/linux/ubuntu-focal-php-phpseclib-2.0.23-2ubuntu0.1-esm3.md) | May 12, 2026 |
| Linux | php-phpseclib Ubuntu 22.04.1 LTS (jammy) | 2.0.36-1ubuntu0.1~esm3 | [php-phpseclib 2.0.36-1ubuntu0.1~esm3](https://patchblox.com/security/data/fix/linux/ubuntu-jammy-php-phpseclib-2.0.36-1ubuntu0.1-esm3.md) | May 12, 2026 |
| Linux | php-phpseclib Ubuntu 24.04.5 LTS (noble) | 2.0.47-1ubuntu0.1~esm1 | [php-phpseclib 2.0.47-1ubuntu0.1~esm1](https://patchblox.com/security/data/fix/linux/ubuntu-noble-php-phpseclib-2.0.47-1ubuntu0.1-esm1.md) | May 12, 2026 |
| Linux | php-phpseclib Ubuntu 26.04.1 LTS (resolute) | 2.0.51-1ubuntu0.1~esm1 | [php-phpseclib 2.0.51-1ubuntu0.1~esm1](https://patchblox.com/security/data/fix/linux/ubuntu-resolute-php-phpseclib-2.0.51-1ubuntu0.1-esm1.md) | May 12, 2026 |
| Linux | php-phpseclib3 Debian 12.15 (bookworm) | 3.0.19-1+deb12u4 | [DSA-6187-1](https://patchblox.com/security/data/fix/linux/dsa-6187-1.md) | Mar 29, 2026 |
| Linux | php-phpseclib3 Debian 13.5 (trixie) | 3.0.43-2+deb13u1 | [DSA-6187-1](https://patchblox.com/security/data/fix/linux/dsa-6187-1.md) | Mar 29, 2026 |
| Linux | php-phpseclib3 Debian 14 | 3.0.50-1 | [DEBIAN-CVE-2026-32935](https://patchblox.com/security/data/fix/linux/debian-cve-2026-32935.md) | Mar 20, 2026 |
| Linux | php-seclib Ubuntu 18.04.6 LTS (bionic) | 1.0.9-1ubuntu0.1~esm2 | [php-seclib 1.0.9-1ubuntu0.1~esm2](https://patchblox.com/security/data/fix/linux/ubuntu-bionic-php-seclib-1.0.9-1ubuntu0.1-esm2.md) | Mar 19, 2026 |
| Linux | php-seclib Ubuntu 20.04 LTS (focal) | 1.0.18-2ubuntu0.1~esm2 | [php-seclib 1.0.18-2ubuntu0.1~esm2](https://patchblox.com/security/data/fix/linux/ubuntu-focal-php-seclib-1.0.18-2ubuntu0.1-esm2.md) | Mar 19, 2026 |
| Linux | php-seclib Ubuntu 22.04.1 LTS (jammy) | 1.0.20-1+deb12u3build0.22.04.1 | [php-seclib 1.0.20-1+deb12u3build0.22.04.1](https://patchblox.com/security/data/fix/linux/ubuntu-jammy-php-seclib-1.0.20-1-deb12u3build0.22.04.1.md) | Mar 19, 2026 |
| Linux | php-seclib Ubuntu 24.04.5 LTS (noble) | 1.0.23-1ubuntu0.1~esm1 | [php-seclib 1.0.23-1ubuntu0.1~esm1](https://patchblox.com/security/data/fix/linux/ubuntu-noble-php-seclib-1.0.23-1ubuntu0.1-esm1.md) | Mar 19, 2026 |
| Linux | php-seclib Ubuntu 26.04.1 LTS (resolute) | 1.0.24-1ubuntu0.1~esm1 | [php-seclib 1.0.24-1ubuntu0.1~esm1](https://patchblox.com/security/data/fix/linux/ubuntu-resolute-php-seclib-1.0.24-1ubuntu0.1-esm1.md) | Mar 19, 2026 |
| Linux | phpseclib Debian 12.15 (bookworm) | 1.0.20-1+deb12u3 | [DSA-6185-1](https://patchblox.com/security/data/fix/linux/dsa-6185-1.md) | Mar 29, 2026 |
| Linux | phpseclib Debian 13.5 (trixie) | 1.0.23-6+deb13u1 | [DSA-6185-1](https://patchblox.com/security/data/fix/linux/dsa-6185-1.md) | Mar 29, 2026 |

---

Data as of 2026-11-08T13:06:02Z UTC. Source: Patchblox Patch Radar (https://patchblox.com/security/patch-radar). Patchblox finds out-of-date software on Windows, macOS and Linux and updates it through release rings: https://patchblox.com/demo

Free to use with attribution: show "Data: Patchblox Patch Radar" with a link to https://patchblox.com/security/patch-radar. Terms, including what needs a written agreement: https://patchblox.com/security/patch-radar/use-the-data

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.
