{
  "cveId": "CVE-2025-66648",
  "url": "https://patchblox.com/security/cve/CVE-2025-66648",
  "summary": "CVE-2025-66648 is fixed in vega.js on 1 platform by DEBIAN-CVE-2025-66648 (version 5.33.1\u002Bds\u002B~cs5.3.0-2), released January 5, 2026. It is not reported as exploited. Patch Radar priority: Routine.",
  "title": "vega.js: vega-functions provides function implementations for the Vega expression language",
  "description": "vega-functions provides function implementations for the Vega expression language. Prior to version 6.1.1, for sites that allow users to supply untrusted user input, malicious use of an internal function (not part of the public API) could be used to run unintentional javascript (XSS). This issue is fixed in vega-functions \u00606.1.1\u0060. There is no workaround besides upgrading. Using \u0060vega.expressionInterpreter\u0060 as described in CSP safe mode does not prevent this issue.",
  "published": "2026-01-05T22:15:51Z",
  "severity": "medium",
  "cvss": 6.1,
  "cvssVector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N",
  "epss": 0.00226,
  "epssPercentile": 0.1333,
  "priority": "Routine",
  "priorityTier": 4,
  "exploited": false,
  "vendorExploited": false,
  "disclosed": false,
  "fixes": [
    {
      "platform": "linux",
      "product": "vega.js",
      "release": "Debian 14",
      "fixedVersion": "5.33.1\u002Bds\u002B~cs5.3.0-2",
      "fix": "DEBIAN-CVE-2025-66648",
      "url": "https://patchblox.com/security/fix/linux/debian-cve-2025-66648",
      "released": "2026-01-05T22:15:51Z"
    }
  ],
  "noFixYet": [],
  "dataAsOf": "2026-11-08T19:12:23Z",
  "attribution": {
    "text": "Data: Patchblox Patch Radar",
    "url": "https://patchblox.com/security/patch-radar",
    "terms": "https://patchblox.com/security/patch-radar/use-the-data"
  }
}