# CVE-2023-50291: lucene-solr: Insufficiently Protected Credentials vulnerability in Apache Solr

CVE-2023-50291 is fixed in lucene-solr on 1 platform, first by DEBIAN-CVE-2023-50291, released February 9, 2024. It is not reported as exploited. Patch Radar priority: High.

- Web page: https://patchblox.com/security/cve/CVE-2023-50291
- Priority: High
- CVSS: 7.5 (high)
- EPSS: 0.0328
- CISA KEV: not listed
- Exploited (vendor report): no
- Publicly disclosed: no
- Published: Feb 9, 2024

## Description

Insufficiently Protected Credentials vulnerability in Apache Solr.  This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.3.0. One of the two endpoints that publishes the Solr process' Java system properties, /admin/info/properties, was only setup to hide system properties that had "password" contained in the name. There are a number of sensitive system properties, such as "basicauth" and "aws.secretKey" do not contain "password", thus their values were published via the "/admin/info/properties" endpoint. This endpoint populates the list of System Properties on the home screen of the Solr Admin page, making the exposed credentials visible in the UI.  This /admin/info/properties endpoint is protected under the "config-read" permission. Therefore, Solr Clouds with Authorization enabled will only be vulnerable through logged-in users that have the "config-read" permission. Users are recommended to upgrade to version 9.3.0 or 8.11.3, which fixes the issue. A single option now controls hiding Java system property for all endpoints, "-Dsolr.hiddenSysProps". By default all known sensitive properties are hidden (including "-Dbasicauth"), as well as any property with a name containing "secret" or "password".  Users who cannot upgrade can also use the following Java system property to fix the issue:   '-Dsolr.redaction.system.pattern=.*(password|secret|basicauth).*'

## Where it's fixed

| Platform | Product | Fixed in | Fix | Released |
|---|---|---|---|---|
| Linux | lucene-solr Debian 12.15 (bookworm) | 3.6.2+dfsg-23 | [DEBIAN-CVE-2023-50291](https://patchblox.com/security/data/fix/linux/debian-cve-2023-50291.md) | Feb 9, 2024 |
| Linux | lucene-solr Debian 13.5 (trixie) | 3.6.2+dfsg-23 | [DEBIAN-CVE-2023-50291](https://patchblox.com/security/data/fix/linux/debian-cve-2023-50291.md) | Feb 9, 2024 |
| Linux | lucene-solr Debian 14 | 3.6.2+dfsg-23 | [DEBIAN-CVE-2023-50291](https://patchblox.com/security/data/fix/linux/debian-cve-2023-50291.md) | Feb 9, 2024 |

---

Data as of 2026-11-08T13:06:02Z UTC. Source: Patchblox Patch Radar (https://patchblox.com/security/patch-radar). Patchblox finds out-of-date software on Windows, macOS and Linux and updates it through release rings: https://patchblox.com/demo

Free to use with attribution: show "Data: Patchblox Patch Radar" with a link to https://patchblox.com/security/patch-radar. Terms, including what needs a written agreement: https://patchblox.com/security/patch-radar/use-the-data

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.
