{
  "cveId": "CVE-2022-29181",
  "url": "https://patchblox.com/security/cve/CVE-2022-29181",
  "summary": "CVE-2022-29181 is fixed in ruby-nokogiri on 1 platform, first by ruby-nokogiri 1.10.7\u002Bdfsg1-2ubuntu0.1~esm2, released May 20, 2022. It is not reported as exploited. Patch Radar priority: High.",
  "title": "ruby-nokogiri: Nokogiri is an open source XML and HTML library for Ruby",
  "description": "Nokogiri is an open source XML and HTML library for Ruby. Nokogiri prior to version 1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers, allowing specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. Version 1.13.6 contains a patch for this issue. As a workaround, ensure the untrusted input is a \u0060String\u0060 by calling \u0060#to_s\u0060 or equivalent.",
  "published": "2022-05-20T12:15:00Z",
  "severity": "high",
  "cvss": 8.2,
  "cvssVector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H",
  "epss": 0.0323,
  "epssPercentile": 0.88334,
  "priority": "High",
  "priorityTier": 3,
  "exploited": false,
  "vendorExploited": false,
  "disclosed": false,
  "fixes": [
    {
      "platform": "linux",
      "product": "ruby-nokogiri",
      "release": "Debian 12.15 (bookworm)",
      "fixedVersion": "1.13.7\u002Bdfsg-1",
      "fix": "DEBIAN-CVE-2022-29181",
      "url": "https://patchblox.com/security/fix/linux/debian-cve-2022-29181",
      "released": "2022-05-20T19:15:08Z"
    },
    {
      "platform": "linux",
      "product": "ruby-nokogiri",
      "release": "Debian 13.5 (trixie)",
      "fixedVersion": "1.13.7\u002Bdfsg-1",
      "fix": "DEBIAN-CVE-2022-29181",
      "url": "https://patchblox.com/security/fix/linux/debian-cve-2022-29181",
      "released": "2022-05-20T19:15:08Z"
    },
    {
      "platform": "linux",
      "product": "ruby-nokogiri",
      "release": "Debian 14",
      "fixedVersion": "1.13.7\u002Bdfsg-1",
      "fix": "DEBIAN-CVE-2022-29181",
      "url": "https://patchblox.com/security/fix/linux/debian-cve-2022-29181",
      "released": "2022-05-20T19:15:08Z"
    },
    {
      "platform": "linux",
      "product": "ruby-nokogiri",
      "release": "Ubuntu 20.04 LTS (focal)",
      "fixedVersion": "1.10.7\u002Bdfsg1-2ubuntu0.1~esm2",
      "fix": "ruby-nokogiri 1.10.7\u002Bdfsg1-2ubuntu0.1~esm2",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-focal-ruby-nokogiri-1.10.7-dfsg1-2ubuntu0.1-esm2",
      "released": "2022-05-20T12:15:00Z"
    },
    {
      "platform": "linux",
      "product": "ruby-nokogiri",
      "release": "Ubuntu 22.04.1 LTS (jammy)",
      "fixedVersion": "1.13.1\u002Bdfsg-2ubuntu0.1~esm1",
      "fix": "ruby-nokogiri 1.13.1\u002Bdfsg-2ubuntu0.1~esm1",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-jammy-ruby-nokogiri-1.13.1-dfsg-2ubuntu0.1-esm1",
      "released": "2022-05-20T12:15:00Z"
    }
  ],
  "noFixYet": [],
  "dataAsOf": "2026-11-08T00:53:09Z",
  "attribution": {
    "text": "Data: Patchblox Patch Radar",
    "url": "https://patchblox.com/security/patch-radar",
    "terms": "https://patchblox.com/security/patch-radar/use-the-data"
  }
}