{
  "cveId": "CVE-2022-25844",
  "url": "https://patchblox.com/security/cve/CVE-2022-25844",
  "summary": "CVE-2022-25844 is fixed in 2 products on 1 platform, first by DEBIAN-CVE-2022-25844, released May 1, 2022. It is not reported as exploited. Patch Radar priority: High.",
  "title": "libjs-angularjs: The package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom...",
  "description": "The package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom locale rule that makes it possible to assign the parameter in posPre: \u0027 \u0027.repeat() of NUMBER_FORMATS.PATTERNS[1].posPre with a very high value. **Note:** 1) This package has been deprecated and is no longer maintained. 2) The vulnerable versions are 1.7.0 and higher.",
  "published": "2022-05-01T09:15:00Z",
  "severity": "Medium",
  "cvss": 7.5,
  "cvssVector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H",
  "epss": 0.04927,
  "epssPercentile": 0.92182,
  "priority": "High",
  "priorityTier": 3,
  "exploited": false,
  "vendorExploited": false,
  "disclosed": false,
  "fixes": [
    {
      "platform": "linux",
      "product": "angular.js",
      "release": "Debian 11.6 (bullseye)",
      "fixedVersion": "1.8.3-1\u002Bdeb12u1~deb11u1",
      "fix": "DLA-4242-1",
      "url": "https://patchblox.com/security/fix/linux/dla-4242-1",
      "released": "2025-07-20T00:00:00Z"
    },
    {
      "platform": "linux",
      "product": "angular.js",
      "release": "Debian 12.15 (bookworm)",
      "fixedVersion": "1.8.3-1\u002Bdeb12u1",
      "fix": "DEBIAN-CVE-2022-25844",
      "url": "https://patchblox.com/security/fix/linux/debian-cve-2022-25844",
      "released": "2022-05-01T16:15:08Z"
    },
    {
      "platform": "linux",
      "product": "angular.js",
      "release": "Debian 13.5 (trixie)",
      "fixedVersion": "1.8.3-2",
      "fix": "DEBIAN-CVE-2022-25844",
      "url": "https://patchblox.com/security/fix/linux/debian-cve-2022-25844",
      "released": "2022-05-01T16:15:08Z"
    },
    {
      "platform": "linux",
      "product": "libjs-angularjs",
      "release": "Ubuntu 20.04 LTS (focal)",
      "fixedVersion": "1.7.9-1ubuntu0.1~esm1",
      "fix": "libjs-angularjs 1.7.9-1ubuntu0.1~esm1",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-focal-libjs-angularjs-1.7.9-1ubuntu0.1-esm1",
      "released": "2025-06-04T10:15:00Z"
    },
    {
      "platform": "linux",
      "product": "libjs-angularjs",
      "release": "Ubuntu 22.04.1 LTS (jammy)",
      "fixedVersion": "1.8.2-2ubuntu0.1",
      "fix": "libjs-angularjs 1.8.2-2ubuntu0.1",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-jammy-libjs-angularjs-1.8.2-2ubuntu0.1",
      "released": "2025-06-04T10:15:00Z"
    },
    {
      "platform": "linux",
      "product": "libjs-angularjs",
      "release": "Ubuntu 24.04.5 LTS (noble)",
      "fixedVersion": "1.8.3-1ubuntu0.24.04.1",
      "fix": "libjs-angularjs 1.8.3-1ubuntu0.24.04.1",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-noble-libjs-angularjs-1.8.3-1ubuntu0.24.04.1",
      "released": "2025-06-04T10:15:00Z"
    }
  ],
  "noFixYet": [],
  "dataAsOf": "2026-11-08T00:53:09Z",
  "attribution": {
    "text": "Data: Patchblox Patch Radar",
    "url": "https://patchblox.com/security/patch-radar",
    "terms": "https://patchblox.com/security/patch-radar/use-the-data"
  }
}