{
  "cveId": "CVE-2022-23304",
  "url": "https://patchblox.com/security/cve/CVE-2022-23304",
  "summary": "CVE-2022-23304 is fixed in 4 products on 1 platform, first by DEBIAN-CVE-2022-23304, released January 17, 2022. It is not reported as exploited. Patch Radar priority: Urgent.",
  "title": "wpa: The implementations of EAP-pwd in hostapd before 2.10 and wpa_supplicant before 2.10 are vulnerable to side-channel a...",
  "description": "The implementations of EAP-pwd in hostapd before 2.10 and wpa_supplicant before 2.10 are vulnerable to side-channel attacks as a result of cache access patterns. NOTE: this issue exists because of an incomplete fix for CVE-2019-9495.",
  "published": "2022-01-16T18:15:00Z",
  "severity": "critical",
  "cvss": 9.8,
  "cvssVector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H",
  "epss": 0.01911,
  "epssPercentile": 0.79931,
  "priority": "Urgent",
  "priorityTier": 2,
  "exploited": false,
  "vendorExploited": false,
  "disclosed": false,
  "fixes": [
    {
      "platform": "linux",
      "product": "hostapd",
      "release": "Ubuntu 20.04 LTS (focal)",
      "fixedVersion": "2:2.9-1ubuntu4.6",
      "fix": "hostapd 2:2.9-1ubuntu4.6",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-focal-hostapd-2-2.9-1ubuntu4.6",
      "released": "2025-02-11T15:15:00Z"
    },
    {
      "platform": "linux",
      "product": "wpa",
      "release": "Debian 12.15 (bookworm)",
      "fixedVersion": "2:2.10-1",
      "fix": "DEBIAN-CVE-2022-23304",
      "url": "https://patchblox.com/security/fix/linux/debian-cve-2022-23304",
      "released": "2022-01-17T02:15:06Z"
    },
    {
      "platform": "linux",
      "product": "wpa",
      "release": "Debian 13.5 (trixie)",
      "fixedVersion": "2:2.10-1",
      "fix": "DEBIAN-CVE-2022-23304",
      "url": "https://patchblox.com/security/fix/linux/debian-cve-2022-23304",
      "released": "2022-01-17T02:15:06Z"
    },
    {
      "platform": "linux",
      "product": "wpa",
      "release": "Debian 14",
      "fixedVersion": "2:2.10-1",
      "fix": "DEBIAN-CVE-2022-23304",
      "url": "https://patchblox.com/security/fix/linux/debian-cve-2022-23304",
      "released": "2022-01-17T02:15:06Z"
    },
    {
      "platform": "linux",
      "product": "wpagui",
      "release": "Ubuntu 20.04 LTS (focal)",
      "fixedVersion": "2:2.9-1ubuntu4.6",
      "fix": "wpagui 2:2.9-1ubuntu4.6",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-focal-wpagui-2-2.9-1ubuntu4.6",
      "released": "2025-02-11T15:15:00Z"
    },
    {
      "platform": "linux",
      "product": "wpasupplicant",
      "release": "Ubuntu 20.04 LTS (focal)",
      "fixedVersion": "2:2.9-1ubuntu4.6",
      "fix": "wpasupplicant 2:2.9-1ubuntu4.6",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-focal-wpasupplicant-2-2.9-1ubuntu4.6",
      "released": "2025-02-11T15:15:00Z"
    }
  ],
  "noFixYet": [],
  "dataAsOf": "2026-11-08T13:06:02Z",
  "attribution": {
    "text": "Data: Patchblox Patch Radar",
    "url": "https://patchblox.com/security/patch-radar",
    "terms": "https://patchblox.com/security/patch-radar/use-the-data"
  }
}