# CVE-2019-10156: ansible: A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, caus...

CVE-2019-10156 is fixed in ansible on 1 platform by ansible 2.5.1+dfsg-1ubuntu0.1 (version 2.5.1+dfsg-1ubuntu0.1), released July 30, 2019. It is not reported as exploited. Patch Radar priority: Routine.

- Web page: https://patchblox.com/security/cve/CVE-2019-10156
- Priority: Routine
- CVSS: n/a (Medium)
- EPSS: 0.0176
- CISA KEV: not listed
- Exploited (vendor report): no
- Publicly disclosed: no
- Published: Jul 30, 2019

## Description

A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.

## Where it's fixed

| Platform | Product | Fixed in | Fix | Released |
|---|---|---|---|---|
| Linux | ansible Ubuntu 18.04.6 LTS (bionic) | 2.5.1+dfsg-1ubuntu0.1 | [ansible 2.5.1+dfsg-1ubuntu0.1](https://patchblox.com/security/data/fix/linux/ubuntu-bionic-ansible-2.5.1-dfsg-1ubuntu0.1.md) | Jul 30, 2019 |

---

Data as of 2026-11-07T12:40:37Z UTC. Source: Patchblox Patch Radar (https://patchblox.com/security/patch-radar). Patchblox finds out-of-date software on Windows, macOS and Linux and updates it through release rings: https://patchblox.com/demo
