{
  "cveId": "CVE-2016-3956",
  "url": "https://patchblox.com/security/cve/CVE-2016-3956",
  "summary": "CVE-2016-3956 is fixed in 2 products on 2 platforms, first by Node.js 4 4.4.2, released April 1, 2016. It is not reported as exploited. Patch Radar priority: High.",
  "title": "Node.js 4: The CLI in npm before 2.15.1 and 3.x before 3.8.3, as used in Node.js 0.10 before 0.10.44, 0.12 before\u2026",
  "description": "The CLI in npm before 2.15.1 and 3.x before 3.8.3, as used in Node.js 0.10 before 0.10.44, 0.12 before 0.12.13, 4 before 4.4.2, and 5 before 5.10.0, includes bearer tokens with arbitrary requests, which allows remote HTTP servers to obtain sensitive information by reading Authorization headers.",
  "published": "2016-07-02T07:59:00Z",
  "severity": "Medium",
  "cvss": 7.5,
  "epss": 0.05456,
  "epssPercentile": 0.92777,
  "priority": "High",
  "priorityTier": 3,
  "exploited": false,
  "vendorExploited": false,
  "disclosed": false,
  "vendorAdvisory": "https://nvd.nist.gov/vuln/detail/CVE-2016-3956",
  "fixes": [
    {
      "platform": "windows-app",
      "product": "Node.js 4",
      "fixedVersion": "4.4.2",
      "fix": "Node.js 4 4.4.2",
      "url": "https://patchblox.com/security/fix/windows-app/openjs.nodejs.4-4.4.2",
      "released": "2016-04-01T00:00:00Z"
    },
    {
      "platform": "linux",
      "product": "npm",
      "release": "Ubuntu 18.04.6 LTS (bionic)",
      "fixedVersion": "3.5.2-0ubuntu4.1.18.04.1~esm1",
      "fix": "npm 3.5.2-0ubuntu4.1.18.04.1~esm1",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-bionic-npm-3.5.2-0ubuntu4.1.18.04.1-esm1",
      "released": "2016-07-02T07:59:00Z"
    }
  ],
  "noFixYet": [],
  "dataAsOf": "2026-11-07T06:34:28Z"
}