# CVE-2016-2157: moodle: Cross-site request forgery (CSRF) vulnerability in mod/assign/adminmanageplugins.php in Moodle through 2.6.11, 2.7.x...

CVE-2016-2157 is fixed in moodle on 1 platform by moodle 3.0.3+dfsg-0ubuntu1 (version 3.0.3+dfsg-0ubuntu1), released May 22, 2016. It is not reported as exploited. Patch Radar priority: Routine.

- Web page: https://patchblox.com/security/cve/CVE-2016-2157
- Priority: Routine
- CVSS: n/a (Low)
- EPSS: 0.0098
- CISA KEV: not listed
- Exploited (vendor report): no
- Publicly disclosed: no
- Published: May 22, 2016

## Description

Cross-site request forgery (CSRF) vulnerability in mod/assign/adminmanageplugins.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote attackers to hijack the authentication of administrators for requests that manage Assignment plugins.

## Where it's fixed

| Platform | Product | Fixed in | Fix | Released |
|---|---|---|---|---|
| Linux | moodle Ubuntu 18.04.6 LTS (bionic) | 3.0.3+dfsg-0ubuntu1 | [moodle 3.0.3+dfsg-0ubuntu1](https://patchblox.com/security/data/fix/linux/ubuntu-bionic-moodle-3.0.3-dfsg-0ubuntu1.md) | May 22, 2016 |

---

Data as of 2026-11-07T18:46:35Z UTC. Source: Patchblox Patch Radar (https://patchblox.com/security/patch-radar). Patchblox finds out-of-date software on Windows, macOS and Linux and updates it through release rings: https://patchblox.com/demo

Free to use with attribution: show "Data: Patchblox Patch Radar" with a link to https://patchblox.com/security/patch-radar. Terms, including what needs a written agreement: https://patchblox.com/security/patch-radar/use-the-data

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.
